社区导航

 

搜索
查看: 561|回复: 0

[资料分享] 关于MSP430 FET-430UIF仿真器

[复制链接]

6412

TA的帖子

19

TA的资源

纯净的硅(初级)

Rank: 4

发表于 2018-3-17 22:23 | 显示全部楼层 |阅读模式
为了使用CCS最新版的一些功能(虽然说相对低一些的版本也有,但是觉得新版本总归是更完善一些吧),安装了CCSV6.1版本。在第一次FET-430UIF仿真器连接电脑的时候,自动安装了对应的VCP驱动(系统为win7 64位)。但是在开始debug的时候,CCS却提示必须更新固件才能继续,虽然有取消按钮,但是取消之后debug也就被终止了,如下图:

360截图20180317222054262.jpg
然后选择了更新固件,连续更新了两次,才能进行正常的debug操作。
后来发现程序运行有不正常的地方,在程序里找bug找了一段时间之后,怀疑是不是操作系统的问题,毕竟win7 64位还是受人诟病的,于是在另外一台电脑上安装了Windows XP双系统,同样安装了CCSV6.1版本。插上仿真器之后,电脑可以识别该仿真器,但是却无法安装驱动,无论是手动还是自动。在网上查找资料之后,发现固件升级到了V3版本,相应的查看仿真器固件版本的方式为(网上方法摘录):
1、在设备管理器的仿真器设备上点击右键,选择“属性”,切换到“详细信息”选项卡,查看“硬件Id”属性;
2、如果显示的是:VID_2047&PID;_0010,表示固件是V3版本;
3、如果显示的是:VID_0451&PID;_F430,表示固件是V2版本;
为了能够在XP上使用,只好选择降级到V2版本的固件,找到一个比较靠谱的软件,软件界面如下图,按照说明提示操作就可以正常实现降级操作
360截图20180317222234659.jpg
大概需要按照提示插拔仿真器3-4次即可(注意阅读软件的注意事项,防止出现失败)。
然后拿到XP上插上,确实可以安装网上可以容易找到的V2版本驱动,顿时开心。但是在debug的时候又提示让升级固件,升级了一次之后,系统不识别仿真器了。。。其实此时,仿真器的固件已经是V3版本了,只是xp系统里没有相应的驱动,在网上找到了对应驱动,下载请移步:点击打开链接(驱动很全面),安装相应驱动之后,仿真器又提示了第二次固件升级(同样是不升级就不给用debug。。。),升级之后即可正常使用。
这个就是今天遇到的情况,希望能够帮到别人。

自己继续补充一点东西,关于仿真器的。
今天使用IAR debug的时候,软件崩掉了,强制关闭之后,再打开发现已经无法识别仿真器了,提示 "fatal error:failed to re-initialize  session aborted!", 然后发现XP系统设备管理器里已经没有显示FET430UIF-CDC这个器件了,但是拔掉还是会有系统提示声音;尝试重启软件及系统均不行。网上有人给出的解决方案是:重启系统并且重新安装驱动。不过我没有这样尝试,选择了重新刷新固件。在win8.1系统下进行降级操作(奇怪的是此时的设备管理器显示有该仿真器的CDC版本器件,特意在该win8.1系统下安装了最新版本的IAR6.3验证是否可以使用,发现是不行的),可能是软件的兼容性问题,降级到一半的时候降级软件的命令行一直提示插与拔掉仿真器,遂停止了这个过程,此时的状态为正在安装VCP版本的固件,两个状态灯全部不亮。卸载掉系统里的仿真器驱动程序之后,安装了VCP版本的驱动程序,然后拿到装有CCS6.1的系统下进行仿真,CCS提示升级固件,确定之后进行了新的固件擦写,至此指示灯开始正常闪烁,我觉得应该OK了。



回复

使用道具 举报

您需要登录后才可以回帖 登录 | 注册

关闭

站长推荐上一条 1/6 下一条

  • 论坛活动 E手掌握

    扫码关注
    EEWORLD 官方微信

  • EE福利  唾手可得

    扫码关注
    EE福利 唾手可得

Archiver|手机版|小黑屋|电子工程世界 ( 京ICP证 060456 )

GMT+8, 2020-6-1 07:49 , Processed in 0.085104 second(s), 22 queries , Gzip On, MemCache On.

快速回复 返回顶部 返回列表