社区导航

 
快捷导航
  • 首页
  • 论坛
  • 查看新帖
  • 最新回复
  • 社区活动
  • 联系管理员
  • 消灭零回复
  • E金币兑换
  • 干货
搜索
查看: 1933|回复: 12

[蓝牙BLE] J-LINK仿真BlueNRG-1时需要更新最新板的软件

[复制链接]

4721

TA的帖子

9

TA的资源

版主

Rank: 6Rank: 6

发表于 2017-12-20 11:18:53 | 显示全部楼层 |阅读模式
我原来的版本是6.00i下载时提示不支持BLUENRG-1

QQ图片20171219084321.png

需要更新到新版才能仿真,比如最新版6.22d
QQ图片20171220111748.png

附上JLink_Windows_V622d.exe
JLink_Windows_V622d.exe (26.06 MB, 下载次数: 24)
虾扯蛋


回复

使用道具 举报

7626

TA的帖子

48

TA的资源

版主

Rank: 6Rank: 6

发表于 2017-12-20 16:51:26 | 显示全部楼层
要死


回复

使用道具 举报

4721

TA的帖子

9

TA的资源

版主

Rank: 6Rank: 6

 楼主| 发表于 2017-12-20 17:04:04 | 显示全部楼层
虾扯蛋


回复

使用道具 举报

2564

TA的帖子

0

TA的资源

版主

Rank: 6Rank: 6

测评达人

发表于 2017-12-21 15:28:49 | 显示全部楼层
玩就玩新的。


回复

使用道具 举报

21

TA的帖子

0

TA的资源

一粒金砂(中级)

Rank: 2

发表于 2017-12-28 09:16:12 | 显示全部楼层
本帖最后由 tang187 于 2017-12-28 09:35 编辑

顶一下,三克油


回复

使用道具 举报

508

TA的帖子

103

TA的资源

纯净的硅(中级)

Rank: 5Rank: 5

发表于 2017-12-29 12:49:12 | 显示全部楼层
我回家先试试ulink2可不可以,如果不行,还得去买个Jlink9

点评

估计ulink2也能更新驱动吧?  详情 回复 发表于 2017-12-29 13:10


回复

使用道具 举报

4721

TA的帖子

9

TA的资源

版主

Rank: 6Rank: 6

 楼主| 发表于 2017-12-29 13:10:39 | 显示全部楼层
gs001588 发表于 2017-12-29 12:49
我回家先试试ulink2可不可以,如果不行,还得去买个Jlink9

估计ulink2也能更新驱动吧?
虾扯蛋


回复

使用道具 举报

21

TA的帖子

0

TA的资源

一粒金砂(中级)

Rank: 2

发表于 6 天前 | 显示全部楼层
有没有人遇到过,更新之后,下载程序会出现The connected J-Link is defective,Proper operation cannot be guaranteed.......

点评

百度你遇到的那句话会有很多解决办法下边是CSDN上的一篇文章 在安装nRF Connect软件时,更新了jlink的驱动(到V6.16a),然后在正常使用KEIL进行下载就出现问题:the connected j-link is defective.Proper operat  详情 回复 发表于 6 天前


回复

使用道具 举报

4721

TA的帖子

9

TA的资源

版主

Rank: 6Rank: 6

 楼主| 发表于 6 天前 | 显示全部楼层
tang187 发表于 2018-1-17 10:51
有没有人遇到过,更新之后,下载程序会出现The connected J-Link is defective,Proper operation cannot be ...

百度你遇到的那句话会有很多解决办法
下边是CSDN上的一篇文章
   在安装nRF Connect软件时,更新了jlink的驱动(到V6.16a),然后在正常使用KEIL进行下载就出现问题:the connected j-link is defective.Proper operation cannot be guaranteed. mdk也变得极不稳定,极易崩溃!
Center
       在网上找解决办法,因为使用的是jlink OB廉价淘宝款,发现大家提到:回溯驱动,有说jlink V6.14后的都不能正常使用,需要用旧版本的JL2CM3.dll和JLinkARM.dll文件覆盖到KeilARMSegger目录,照做,发现没有解决问题,然后下载了6.10i版本和4.08版本的驱动,安装没用,用文件覆盖没用,删除了高版本的文件夹,还是会崩溃。
Center
Center
      然后急于使用MDK,就用了最管用最笨的办法,将jink和keil 全卸载了,删掉文件夹,重新安装,当然结果就是可以用了,虽然笨了点。。。
     一台电脑需要同时使用V8/V9和OB,可能也会存在驱动问题,网上可以下到的4合一驱动版本为4.6,我使用的6.10版本也可以同时驱动这几个设备,有时候Error: Flash Download failed  -  Target DLL has been cancelled并不是因为驱动或者MCU中在跑的代码的问题,可以就是板子的电源和jlink是分开的,你需要再给板子把电源线接上,很多时候我们习惯了jlink给板子供电就没有考虑到这一点。

虾扯蛋


回复

使用道具 举报

508

TA的帖子

103

TA的资源

纯净的硅(中级)

Rank: 5Rank: 5

发表于 6 天前 | 显示全部楼层
本帖最后由 gs001588 于 2018-1-17 23:14 编辑

我买了山寨超级简陋版Jlink V9,安装了JLink_Windows_V622d.exe,并且Jlink升级了最新固件。在IAR下是好的,但在Keil MDK 5.22版本下刚也是各种不适应。
后来发现,keil软件调用了自带的Jlink驱动文件夹中的驱动,而没有调用V622的,试着把JLink下的JLinkARM.dll文件覆盖到Keil ARM Segger下,还是有问题,提示电压超了。
最后直接下载最新版本keil MDK 5.24A,自带的jlink驱动版本是6.16c,一切正常,用了几天,没发现再出问题。回家发个贴,各种姿势连 BlueNRG-1。ulink2、stlink v2、jlink v9,都试过了,是都可以可以的。


回复

使用道具 举报

21

TA的帖子

0

TA的资源

一粒金砂(中级)

Rank: 2

发表于 6 天前 | 显示全部楼层
littleshrimp 发表于 2018-1-17 12:29
百度你遇到的那句话会有很多解决办法下边是CSDN上的一篇文章   在安装nRF Connect软件时,更新了jlink的 ...

谢谢您的回答。


回复

使用道具 举报

21

TA的帖子

0

TA的资源

一粒金砂(中级)

Rank: 2

发表于 6 天前 | 显示全部楼层
tang187 发表于 2018-1-17 13:29
谢谢您的回答。

能分享一下您的软件吗?谢谢


回复

使用道具 举报

5

TA的帖子

0

TA的资源

一粒金砂(初级)

Rank: 1

发表于 4 天前 | 显示全部楼层
现在淘宝都出来盗版V10了都


回复

使用道具 举报

您需要登录后才可以回帖 登录 | 注册

本版积分规则

  • 论坛活动 E手掌握

    扫码关注
    EEWORLD 官方微信

  • EE福利  唾手可得

    扫码关注
    EE福利 唾手可得

小黑屋|手机版|Archiver|电子工程世界 ( 京ICP证 060456

GMT+8, 2018-1-23 21:58 , Processed in 0.353711 second(s), 17 queries , Redis On.

快速回复 返回顶部 返回列表