社区导航

 
快捷导航
  • 首页
  • 论坛
  • 查看新帖
  • 最新回复
  • 社区活动
  • 联系管理员
  • 消灭零回复
  • E金币兑换
  • 干货
搜索
查看: 738|回复: 9

[求助] SPWM单相正弦逆变波形问题

[复制链接]

20

TA的帖子

0

TA的资源

一粒金砂(初级)

Rank: 1

发表于 2017-7-16 12:49:43 | 显示全部楼层 |阅读模式
spwm逆变的正弦波总是在固定的地方有个尖峰,,可能是因为什么啊?
用的是msp430单片机产生的SPWM。

此帖出自电源技术论坛

本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?注册

x


回复

使用道具 举报

1万

TA的帖子

287

TA的资源

版主

Rank: 6Rank: 6

发表于 2017-7-17 10:45:39 | 显示全部楼层
有尖峰是因为干扰的问题,只能这样分析


回复

使用道具 举报

20

TA的帖子

0

TA的资源

一粒金砂(初级)

Rank: 1

 楼主| 发表于 2017-7-17 11:07:09 | 显示全部楼层
qwqwqw2088 发表于 2017-7-17 10:45
有尖峰是因为干扰的问题,只能这样分析

正弦表是通过正弦函数直接生成的,,今天我观察了MSP430的SPWM输出,发现输出的地方有一个异常波形,不知道为什么会有,正对应着尖峰,导致了失真。


回复

使用道具 举报

20

TA的帖子

0

TA的资源

一粒金砂(初级)

Rank: 1

 楼主| 发表于 2017-7-17 11:08:00 | 显示全部楼层
这是源代码

本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?注册

x


回复

使用道具 举报

1万

TA的帖子

287

TA的资源

版主

Rank: 6Rank: 6

发表于 2017-7-17 16:38:20 | 显示全部楼层
可能与硬件电路有关
考虑LC滤波参数是否设计的合理,
加大电感或在输出末端加共模电感,可以尝试把输出电流的高频毛刺吸收,,,


回复

使用道具 举报

1万

TA的帖子

33

TA的资源

版主

Rank: 6Rank: 6

发表于 2017-7-17 17:16:20 | 显示全部楼层
固定位置的干扰,也可以怀疑正弦波表出错造成。

看看电路中,有没有与此频率一致的干扰源。


回复

使用道具 举报

5

TA的帖子

0

TA的资源

一粒金砂(初级)

Rank: 1

发表于 2017-7-20 15:20:48 | 显示全部楼层
我也遇到了跟你同样的问题,反复检查正弦表,检查硬件也无果。最后改变滤波让这个峰变得不明显可以忽略了。我的要求不是很严格,就先这样处理了。找到问题跟我也说一声啊


回复

使用道具 举报

5

TA的帖子

0

TA的资源

一粒金砂(初级)

Rank: 1

发表于 2017-7-20 15:21:23 | 显示全部楼层
尖峰波形的位置都跟你一样


回复

使用道具 举报

5

TA的帖子

0

TA的资源

一粒金砂(初级)

Rank: 1

发表于 2017-7-20 15:22:46 | 显示全部楼层
我用的430 2231


回复

使用道具 举报

20

TA的帖子

0

TA的资源

一粒金砂(初级)

Rank: 1

 楼主| 发表于 2017-7-21 20:02:00 | 显示全部楼层
zxgvbzxgvb 发表于 2017-7-20 15:20
我也遇到了跟你同样的问题,反复检查正弦表,检查硬件也无果。最后改变滤波让这个峰变得不明显可以忽略了。 ...

程序好像在那个位置,定时器无法处理,我将正弦表的抑制比调到0.9以下,就没有了


回复

使用道具 举报

您需要登录后才可以回帖 登录 | 注册

本版积分规则

  • 论坛活动 E手掌握

    扫码关注
    EEWORLD 官方微信

  • EE福利  唾手可得

    扫码关注
    EE福利 唾手可得

小黑屋|手机版|Archiver|电子工程世界 ( 京ICP证 060456

GMT+8, 2017-11-18 16:19 , Processed in 0.474886 second(s), 15 queries , Redis On.

快速回复 返回顶部 返回列表