社区导航

 
快捷导航
  • 首页
  • 论坛
  • 查看新帖
  • 最新回复
  • 社区活动
  • 联系管理员
  • 消灭零回复
  • E金币兑换
  • 干货
搜索
查看: 2250|回复: 11

[求助] 诡异的GPIO上拉电压不足问题,求解!!

[复制链接]

5

TA的帖子

0

TA的资源

一粒金砂(中级)

Rank: 2

发表于 2017-1-23 18:22:24 | 显示全部楼层 |阅读模式
本人用STM32L073的Nucleo板子,现在用GPIOC的0~7的管脚输出,控制MOS管。
管脚模式设置为OD,内部上下拉关闭,每个管脚都外部接4.2V上拉的1K电阻,结果发现其他管脚都输出正常有4.2V左右,而GPIO0这个管脚输出只有2.3V左右,我把其他外部接线跟GPIO0的接线互换,GPIO0管脚上的接线还是会同样的出现电压只有2V多的问题,因而排除了外部接线的问题,我怀疑问题可能出在代码或者板子内部,但0~7的管脚输出代码设置是统一设置的,而我搜索了一下整个工程代码,其他地方也没有用到GPIO0这个管脚的,我就奇怪了,到底是咋回事呢?哪位大神知道,请赐教!

  GPIO_InitStruct.Mode  = GPIO_MODE_OUTPUT_OD;
  GPIO_InitStruct.Pull  = GPIO_NOPULL;
  GPIO_InitStruct.Speed = GPIO_SPEED_FREQ_LOW;

  GPIO_InitStruct.Pin = GPIO_PIN_0|GPIO_PIN_1|GPIO_PIN_2|GPIO_PIN_3|GPIO_PIN_4|GPIO_PIN_5|GPIO_PIN_6;
  HAL_GPIO_Init(GPIOC, &GPIO_InitStruct);


此帖出自stm32/stm8论坛


回复

使用道具 举报

1012

TA的帖子

1

TA的资源

版主

Rank: 6Rank: 6

发表于 2017-1-24 08:07:08 | 显示全部楼层
你上拉4.2V有问题,得确定引脚是否支持5V,如果不支持会烧坏MCU


回复

使用道具 举报

4164

TA的帖子

9

TA的资源

五彩晶圆(高级)

Rank: 9Rank: 9Rank: 9

测评达人

发表于 2017-1-24 10:01:50 | 显示全部楼层
同意二楼的说法,不要随意的接4.2v的上拉,至少要看看datasheet,保证这个gpio都是5v容忍的。


回复

使用道具 举报

5

TA的帖子

0

TA的资源

一粒金砂(中级)

Rank: 2

 楼主| 发表于 2017-1-24 10:19:04 | 显示全部楼层
qwerghf 发表于 2017-1-24 08:07
你上拉4.2V有问题,得确定引脚是否支持5V,如果不支持会烧坏MCU

我在外接上拉电压时,已经查过手册了,管脚是FT的,也就是可以容忍5V输入的。
关键让我费解的事,其他管脚都没问题,为啥偏偏这一个GPIO0的管脚拉不起来电压。

点评

是否有这样的可能,这个IO的复用功能默认是打开的  详情 回复 发表于 2017-1-24 16:52
这样的话,我建议你用stm32CubeMX单独拉出来,然后单独配置,看看IO的电平是否正常。  详情 回复 发表于 2017-1-24 12:05


回复

使用道具 举报

4164

TA的帖子

9

TA的资源

五彩晶圆(高级)

Rank: 9Rank: 9Rank: 9

测评达人

发表于 2017-1-24 12:05:34 | 显示全部楼层
yyyggg 发表于 2017-1-24 10:19
我在外接上拉电压时,已经查过手册了,管脚是FT的,也就是可以容忍5V输入的。
关键让我费解的事,其他管 ...

这样的话,我建议你用stm32CubeMX单独拉出来,然后单独配置,看看IO的电平是否正常。


回复

使用道具 举报

3169

TA的帖子

0

TA的资源

版主

Rank: 6Rank: 6

发表于 2017-1-24 14:28:57 | 显示全部楼层
电路上是不是接了其它东西啊


回复

使用道具 举报

469

TA的帖子

0

TA的资源

五彩晶圆(中级)

Rank: 8Rank: 8

发表于 2017-1-24 16:52:19 | 显示全部楼层
yyyggg 发表于 2017-1-24 10:19
我在外接上拉电压时,已经查过手册了,管脚是FT的,也就是可以容忍5V输入的。
关键让我费解的事,其他管 ...

是否有这样的可能,这个IO的复用功能默认是打开的


回复

使用道具 举报

1260

TA的帖子

4

TA的资源

纯净的硅(高级)

Rank: 6Rank: 6

发表于 2017-1-24 17:11:15 | 显示全部楼层
开漏模式
天地庄周马;江湖范蠡船。
个性签名还是放QQ号吧,2060347305,添加说明EEworld好友


回复

使用道具 举报

1万

TA的帖子

146

TA的资源

版主

Rank: 6Rank: 6

技术导师勋章

发表于 2017-1-24 18:06:01 | 显示全部楼层
注意看手册,注意该IO与其它IO的区别,尤其是该管脚是多用途的需格外留意其上电默认态。
上传了一些书籍资料,也许有你想要的:http://download.eeworld.com.cn/user/chunyang


回复

使用道具 举报

3463

TA的帖子

11

TA的资源

五彩晶圆(高级)

Rank: 9Rank: 9Rank: 9

发表于 2017-1-24 18:37:16 | 显示全部楼层
先不上电,测一下GPIO0对地的电阻。看看硬件是否正常。还可以把它设成推挽输出,不接外部上拉,看看电压电压是否正常。


回复

使用道具 举报

5

TA的帖子

0

TA的资源

一粒金砂(中级)

Rank: 2

 楼主| 发表于 2017-1-25 11:21:24 | 显示全部楼层
ienglgge 发表于 2017-1-24 18:37
先不上电,测一下GPIO0对地的电阻。看看硬件是否正常。还可以把它设成推挽输出,不接外部上拉,看看电压电 ...

按你方法,测了一下GPIO0对地的电阻,700欧出头,其他管脚也对比测了,都是750欧~790欧这个数值,这能说明管脚坏了吗?
设置成推挽输出管脚电压是没问题的。


回复

使用道具 举报

5

TA的帖子

0

TA的资源

一粒金砂(中级)

Rank: 2

 楼主| 发表于 2017-1-25 11:23:00 | 显示全部楼层
我现在换了块L053的板子,同样的程序代码,现在运行正常,我去,虽然问题解决了,但原因不明,还是不知道咋造成的?


回复

使用道具 举报

您需要登录后才可以回帖 登录 | 注册

本版积分规则

  • 论坛活动 E手掌握

    扫码关注
    EEWORLD 官方微信

  • EE福利  唾手可得

    扫码关注
    EE福利 唾手可得

小黑屋|手机版|Archiver|电子工程世界 ( 京ICP证 060456

GMT+8, 2018-7-20 18:18 , Processed in 1.009978 second(s), 23 queries , Gzip On, Redis On.

快速回复 返回顶部 返回列表