社区导航

 
快捷导航
  • 首页
  • 论坛
  • 查看新帖
  • 最新回复
  • 社区活动
  • 联系管理员
  • 消灭零回复
  • E金币兑换
  • 干货
搜索
查看: 1304|回复: 1

[经验] 说一下DSP6000的电源供电

[复制链接]

1047

TA的帖子

0

TA的资源

一粒金砂(中级)

Rank: 2

发表于 2017-1-23 08:25:56 | 显示全部楼层 |阅读模式
1. DSP6000上电顺序的问题

DSP的确是个怪胎,常见的两个问题就是:(1)连接不上CCS开发环境;(2)烧芯片。我现在使用的是TMS320C6713,以下经验都基于DSP6000,其它系列或有不同。似乎现在芯片性能变好了,也没烧过芯片,但CCS还是经常出现连接不上的情况。


其中一部分原因与硬件的稳定性有关,注意在设计电源电路时就最好要保证1.2V的内核电压先上电,3.3V的IO口电压后上电。


还有一个很重要的原因就是DSP板,DSP电源开关和CCS三者之间的连接顺序也很重要,之前的连接错误常常导致无法连接CCS,CCS死机等莫名其妙的情况。


通过尝试,总结下正确的上电连接做法:

(1)将DSP板、XDS510仿真器、PC断开,CCS软件关闭

(2)将XDS510仿真器连接DSP开发板

(3)将XDS510仿真器连接PC机的USB口,等待一段时间(很重要,XDS510仿真器上有个指示灯,等待到指示灯从亮变灭)

(4)打开DSP板的电源开关

(5)打开CCS软件,别急着连接,等待一段时间(几秒吧)

(6)从CCS上使用Alt+C或Debug/Connect连接仿真器


按上述6步,连接成功率还是比较高的。


下电操作也很重要,有人还没把CCS的连接断开,直接就把仿真器拔了或DSP的电断了,然后恭喜你看到一个红色的“Error 0x18....”,我的做法是:

(1)使用Alt+C快捷键或Debug/Unconnect断开CCS与仿真器的连接

(2)断开DSP的供电电源

(3)断开仿真器与PC的USB口连接

(4)断开仿真器与DSP的连接

之前常常将(3)(4)步颠倒,发现也会出现不少问题。切记,一定先断DSP的电再进行其他的插拔操作。



2. DSP6000的1.2V内核电压在调试PCB板过程中,我总是习惯在上电前用万用表测量电源和地是否短路。


那天,问题出现了,我用万用表(黑皮的那种)测DSP的1.2V电源和地,可怕的“滴...滴”声响了。奇怪了,不会吧,我电路焊得那么认真,别开玩笑了,然后开始检查电路,不断的加焊,检查每一处1.2V的位置,依然没发现问题。换了个万用表(还是黑皮的那种),“大哥”,我快跪了,又不敢上电。


当时DSP板上接有一个FPGA,难道是FPGA的问题,坏了,把FPGA卸了,还是短路。然后1.2V电源模块也卸了.......短路。


最后,没发现问题,把板子搁置在一边,过了几天,老板逼着,得调啊,又找个万用表(这次是红皮的那种),一测,诶,OK,神了,板子居然休息休息就能用了。


但科学告诉我:这是不可能的,短路不可能变成不短路。


又拿原来的万用表(黑皮的那种)测,“滴滴”,弄得我心惊肉条,还是短路。红皮的测,不短路。


豁出去了,给DSP直接上电,烧就烧吧!上电,连接仿真器,OK,CCS连接成功了。


这就得思考了,断电后用电压表的欧姆档测了一下1.2V与地之间的电阻,70多欧姆(这是DSP的内核的内阻值,略小啊),即不同万用表判定短路的阈值电阻值不同,红色的万用表阈值比黑色的低。


此帖出自DSP论坛


回复

使用道具 举报

2681

TA的帖子

0

TA的资源

纯净的硅(高级)

Rank: 6Rank: 6

发表于 2017-1-23 13:42:21 | 显示全部楼层
我还是习惯用电阻档去测量短路,这样比较准确,贴别是一些低电压的地方。
作为一个水军,就是尽量的多回帖,因为懂的技术少,所以回帖水分大,见谅!
EEWORLD开发板置换群:309018200,——电工们免费装β的天堂,商家勿入!加群暗号:喵


回复

使用道具 举报

您需要登录后才可以回帖 登录 | 注册

本版积分规则

  • 论坛活动 E手掌握

    扫码关注
    EEWORLD 官方微信

  • EE福利  唾手可得

    扫码关注
    EE福利 唾手可得

小黑屋|手机版|Archiver|电子工程世界 ( 京ICP证 060456

GMT+8, 2018-4-22 14:22 , Processed in 0.083877 second(s), 17 queries , Redis On.

快速回复 返回顶部 返回列表