社区导航

 

搜索
查看: 2577|回复: 9

[求助] 逆变电路直通问题

[复制链接]

478

TA的帖子

1

TA的资源

一粒金砂(高级)

Rank: 3Rank: 3

发表于 2015-8-3 19:21 | 显示全部楼层 |阅读模式
本帖最后由 flashtt 于 2015-8-3 19:45 编辑

焊接的逆变电路出现直通,虽然不是完全的直通,没有带载电流很大,我慢慢放开限流,电流逐渐增大,电压一点点上升,输出已经有正弦波的样子了,期间还烧了一个mos管,

电流全部都从mos管直通了,用的芯片是UCC27211,按理说是不用写死区的,之前搭的同步buck和半桥逆变都没有问题,对全桥逆变的工作过程有些不理解,希望有相关经验的人能帮忙解答


电路图如下,两个自举端HS是接的,图中没画

1.JPG

电路板如下,此时测试的输入是信号源给的互补方波,用msp432的SPWM波暂时没用,不过用来半桥逆变是没问题的,电感在下面,自己绕的约1mH的电感
IMG_0123.JPG
这是限流限在0.43A的情况,不敢开太大,电流都从mos管走掉了,电压只有0.2V,不过此时输出已经有正弦波的样子了,由于示波器只有两通道,一个通道显示的是一个栅极的波形,另外一个是一个微小的正弦波,是用PWM波滤的,不像正弦波很正常

IMG_0124.JPG IMG_0125.JPG

再发两张栅极波形

IMG_0126.JPG IMG_0127.JPG



栅极波形看起来”正常“,结合半桥整流工作正常,我非常不理解电流出现在何时,我个人认为主要不是没写死区造成的,毕竟驱动器能自己产生一定的死区,

是不是换流时产生的电流尖峰,我的电源基础知识不足,手头的条件也很不足,希望大家帮帮忙,谢谢


回复

使用道具 举报

22

TA的帖子

0

TA的资源

一粒金砂(中级)

Rank: 2

发表于 2015-8-3 19:48 | 显示全部楼层
这个驱动芯片是用自举电容?我怎么没看到,桥臂中点接在芯片哪个位置?

点评

HS端,原理图上漏画了,这个芯片自举二极管在内部,HB和HS脚之间外接一个0.1uF的自举电容  详情 回复 发表于 2015-8-3 20:37


回复

使用道具 举报

478

TA的帖子

1

TA的资源

一粒金砂(高级)

Rank: 3Rank: 3

 楼主| 发表于 2015-8-3 20:37 | 显示全部楼层
抬头 发表于 2015-8-3 19:48
这个驱动芯片是用自举电容?我怎么没看到,桥臂中点接在芯片哪个位置?

HS端,原理图上漏画了,这个芯片自举二极管在内部,HB和HS脚之间外接一个0.1uF的自举电容


回复

使用道具 举报

2821

TA的帖子

0

TA的资源

五彩晶圆(初级)

Rank: 7Rank: 7Rank: 7

发表于 2015-8-3 20:44 | 显示全部楼层
你可以这样测试一下桥臂直通,把电压加到单独一个桥臂上,看下电流是不是有那么大。不要外接任何东西。
作为一个水军,就是尽量的多回帖,因为懂的技术少,所以回帖水分大,见谅!
EEWORLD开发板置换群:309018200,——电工们免费装β的天堂,商家勿入!加群暗号:喵


回复

使用道具 举报

22

TA的帖子

0

TA的资源

一粒金砂(中级)

Rank: 2

发表于 2015-8-3 21:31 | 显示全部楼层
那你就直接测一下桥臂两个管子的驱动波形不就得了么?不过那样得有差分


回复

使用道具 举报

478

TA的帖子

1

TA的资源

一粒金砂(高级)

Rank: 3Rank: 3

 楼主| 发表于 2015-8-4 07:49 | 显示全部楼层
从我贴出的波形结合半桥逆变的波形来看,正常情况下是不会直通的,请哪位有逆变电路设计经验的人能帮我分析一下出现那么大电流的可能原因,因为我对全桥逆变的工作原理不是很了解


回复

使用道具 举报

1万

TA的帖子

33

TA的资源

版主

Rank: 6Rank: 6

发表于 2015-8-4 11:10 | 显示全部楼层
死区是需要的,
管子的Ciss( Input Capacitance ) 9380 (12200) pF,这么大的电容,不加死区是不行的。

点评

经过我的测试,死区是不必要的,至少不是平常想的那种死区,毕竟同步buck和半桥逆变是没问题的,应该是我对全桥逆变的理解有问题,不是同一个驱动器的上管和下管导通,是两个上管同时导通或者两个下管,或者是不知道  详情 回复 发表于 2015-8-4 12:13


回复

使用道具 举报

478

TA的帖子

1

TA的资源

一粒金砂(高级)

Rank: 3Rank: 3

 楼主| 发表于 2015-8-4 12:13 | 显示全部楼层
本帖最后由 flashtt 于 2015-8-4 12:39 编辑
dontium 发表于 2015-8-4 11:10
死区是需要的,
管子的Ciss( Input Capacitance ) 9380 (12200) pF,这么大的电容,不加死区是不行的 ...

经过我的测试,死区不是主要原因,毕竟同步buck和半桥逆变是没问题的,我刚才用了较大死区的PWM波都有很大的电流,应该是我对全桥逆变的理解有问题,不是同一个驱动器的上管和下管导通,是两个上管同时导通或者两个下管,或者是不知道哪里出现的电流尖峰,我在看关于逆变直通的相关文章,希望能找到解决方案


回复

使用道具 举报

478

TA的帖子

1

TA的资源

一粒金砂(高级)

Rank: 3Rank: 3

 楼主| 发表于 2015-8-4 21:10 | 显示全部楼层
找到问题了,是电感用的磁芯的问题,可能是电感饱和了,重绕了一个就没有电流了,但现在新的问题来了,我上电再下电测试的过程中一会芯片就烧掉了,继续想原因吧,可能是空载放电的问题

点评

不能用磁导率太高的磁芯,不稳定容易饱和,绕了几圈就有mH级了  详情 回复 发表于 2015-8-5 13:40


回复

使用道具 举报

478

TA的帖子

1

TA的资源

一粒金砂(高级)

Rank: 3Rank: 3

 楼主| 发表于 2015-8-5 13:40 | 显示全部楼层
flashtt 发表于 2015-8-4 21:10
找到问题了,是电感用的磁芯的问题,可能是电感饱和了,重绕了一个就没有电流了,但现在新的问题来了,我上 ...

不能用磁导率太高的磁芯,不稳定容易饱和,绕了几圈就有mH级了


回复

使用道具 举报

您需要登录后才可以回帖 登录 | 注册

关闭

站长推荐上一条 1/4 下一条

  • 论坛活动 E手掌握

    扫码关注
    EEWORLD 官方微信

  • EE福利  唾手可得

    扫码关注
    EE福利 唾手可得

Archiver|手机版|小黑屋|电子工程世界 ( 京ICP证 060456 )

GMT+8, 2020-6-7 05:48 , Processed in 0.343778 second(s), 32 queries , Gzip On, MemCache On.

快速回复 返回顶部 返回列表