社区导航

 

搜索
查看: 1717|回复: 8

[求助] 用BQ78PL116开发的电池管理系统,大电流放电时会出现VLAN报警

[复制链接]

6

TA的帖子

0

TA的资源

一粒金砂(中级)

Rank: 2

发表于 2015-7-30 13:57 | 显示全部楼层 |阅读模式
     我们公司在使用一套BMS,由别的公司开发的,使用BQ78PL116芯片,配有一个液晶屏显示信息,BMS的直流输出端接到一台逆变器的输入端,逆变器输出AC127V,然后在这里挂一些老化用的阻性负载。
     当负载功率在500W以下时,BMS工作没有问题,当负载功率大于500W时,工作就不太稳定了,比如BMS输出电流在17A(锂离子电池包电压37V--41V)时,BMS工作几分钟后,显示屏会显示“VLAN”报警,直流输出也就没有了。

     有些别的设备,显示屏会出现死机故障,显示屏上的时间就不再跳动了,几秒钟或者十几秒钟后显示屏重启,这段时间内直流输出就没有的。等显示屏启动起来之后,工作几分钟或者十几分钟还是会出现死机、重启的故障。

      针对上面出现的两种故障,供应商之前怀疑是BMS与显示屏之间的通讯受到干扰,然后第二批供货时将通讯线换成屏蔽线,6台设备都没有问题。但第三批货又出现了之前的那种问题,现在供应商也没有太好的办法了,看看我们这里有没有热心朋友能帮帮忙啊!!!       这批货很着急,也很重要啊!



P50730-085628.jpg
P50730-135148.jpg


回复

使用道具 举报

2万

TA的帖子

333

TA的资源

版主

Rank: 6Rank: 6

发表于 2015-7-30 17:17 | 显示全部楼层
大电流到17A报警,测量一下温度是否变化?
BQ78PL116应该在调试阶段要写入温度保护参数,问一下给开发的“别的公司”这个温度值是否过低,提前保护了


回复

使用道具 举报

6

TA的帖子

0

TA的资源

一粒金砂(中级)

Rank: 2

 楼主| 发表于 2015-7-31 11:41 | 显示全部楼层
qwqwqw2088 发表于 2015-7-30 17:17
大电流到17A报警,测量一下温度是否变化?
BQ78PL116应该在调试阶段要写入温度保护参数,问一下给开发的“ ...

温度、电压这些数据都没有问题的。         
现在,问题算是解决了,昨天下午,供应商建议将屏蔽线的包裹层跟BMS的P-短接到一起,然后用绝缘垫片和塑料支柱将显示屏和壳体隔离开。    昨天傍晚弄好了一台,放电两个半小时至放电结束,都没有再出现之前的故障。今天上午改装了4台,目前为止放电两小时,也没有发现问题,感觉问题应该算是解决了,应该还是SMBus通信受到干扰的原因。     
后面继续老化测试,继续观察。
谢谢朋友热心回复。

点评

谢谢分享问题的原因。 发送和接收消息都是通过 SMBus,受干扰时问题确实不好查找。  详情 回复 发表于 2015-8-2 15:54


回复

使用道具 举报

2万

TA的帖子

333

TA的资源

版主

Rank: 6Rank: 6

发表于 2015-8-2 15:54 | 显示全部楼层
864787830@qq 发表于 2015-7-31 11:41
温度、电压这些数据都没有问题的。         
现在,问题算是解决了,昨天下午,供应商建议将屏蔽线的包 ...

谢谢分享问题的原因。
发送和接收消息都是通过 SMBus,受干扰时问题确实不好查找。


回复

使用道具 举报

6

TA的帖子

0

TA的资源

一粒金砂(中级)

Rank: 2

 楼主| 发表于 2015-8-2 21:11 | 显示全部楼层
qwqwqw2088 发表于 2015-8-2 15:54
谢谢分享问题的原因。
发送和接收消息都是通过 SMBus,受干扰时问题确实不好查找。

不好意思,后面再次老化放电工作一两个小时,又出现了原来的故障。      后来,我们在P-那条线上套了三个磁环、将SMBus通讯线剪掉一截这两种办法,问题还是存在。                     今天下午,供应商建议用一段铁皮管将通讯线完全包裹住,准备明天上午试试,希望有好的表现。
后面我会及时跟大家回馈情况。


回复

使用道具 举报

6

TA的帖子

0

TA的资源

一粒金砂(中级)

Rank: 2

 楼主| 发表于 2015-8-3 13:56 | 显示全部楼层
供应商建议将通讯线的屏蔽层短接到B-(电池包负极),试了,效果还是不行。     现在供应商只有一招了:将BMS和显示器的通讯方式更换成RS-485,等他们新的样机中。


回复

使用道具 举报

6

TA的帖子

0

TA的资源

一粒金砂(中级)

Rank: 2

 楼主| 发表于 2015-8-23 20:58 | 显示全部楼层
上面的问题,现在有了新的进展。      1、周四的时候,我们做了实验,在逆变器交流输出端接入大功率负载,BMS工作电流18A,显示屏时钟秒针忽快忽慢,不太稳定,平均工作5分钟就会出现一次显示屏死机重启的这种故障。然后降低逆变器输出端负载功率,BMS工作电流15A左右,显示屏工作稳定,一切正常。接着,在BMS直流输出端再并联接入两台模拟电子负载,载入电流6.5A,加一起,BMS的工作电流就是21.5A左右,老化工作半小时,一切正常。由于模拟电子负载载入的电流属于阻性负载,由此我们初步判断,逆变器大电流工作时影响到了BMS和显示屏,怀疑是逆变器的问题。
2、周五,逆变器供应商来了,检查了一下逆变器大电流工作时的输入波形,认为他们的逆变器没有问题,然后排查显示屏,怀疑是显示屏供电端工作不稳定,影响到了单片机工作,建议在显示屏的电源线上串入磁环,刚开始我不相信,没想到还真解决了问题,之后逆变器高负荷工作老化半小时,显示屏一切正常,时钟正常。
3、之后,在显示屏模块上接入485通信线的时候,发现平均两分钟,显示屏就会出现“VLAN”报警,有了之前的经验,再次在485通信线上串入磁环,后面老化工作近2两个小时,一切OK!
周六又做了3个半小时的老化,一切正常。估计,这个问题应该就解决了,下周还有几台产品会装好,到时候再多老化几台,看看情况,希望一些顺利!
4、如果后面我不再更新,就说明之前的问题解决了。
总结,初步判断,问题原因:显示屏电源端和485通信端滤波电路做的不好,抗干扰能力较差,加入磁环滤波。
后面附带的照片里,两个红色的圈圈里就是我们串入的磁环。

P50821-172509.jpg

点评

恭喜楼主找到问题所在 嘿嘿  详情 回复 发表于 2015-8-24 09:58


回复

使用道具 举报

2万

TA的帖子

74

TA的资源

管理员

Rank: 13Rank: 13Rank: 13Rank: 13

发表于 2015-8-24 09:58 | 显示全部楼层
864787830@qq 发表于 2015-8-23 20:58
上面的问题,现在有了新的进展。      1、周四的时候,我们做了实验,在逆变器交流输出端接入大功率负载,B ...

恭喜楼主找到问题所在 嘿嘿

不管是哪年,都要加油!继续为中国电子行业做出小小的贡献吧! 扣扣 1206973913



回复

使用道具 举报

2万

TA的帖子

333

TA的资源

版主

Rank: 6Rank: 6

发表于 2015-8-25 16:44 | 显示全部楼层
不错
看来问题接近的很巧妙,磁环在抑制电源线、信号线上的干扰很好


回复

使用道具 举报

您需要登录后才可以回帖 登录 | 注册

关闭

站长推荐上一条 1/7 下一条

  • 论坛活动 E手掌握

    扫码关注
    EEWORLD 官方微信

  • EE福利  唾手可得

    扫码关注
    EE福利 唾手可得

Archiver|手机版|小黑屋|电子工程世界 ( 京ICP证 060456 )

GMT+8, 2020-5-26 14:33 , Processed in 0.304734 second(s), 33 queries , Gzip On, MemCache On.

快速回复 返回顶部 返回列表