1129|4

2万

帖子

337

资源

版主

分享:BQ40Z80 一直打嗝的解决 [复制链接]

本帖最后由 qwqwqw2088 于 2020-8-11 09:12 编辑

BQ40Z80是TI的一款采用 Impedance Track™ 电量监测技术的 2 节至 7 节电池组管理器

故障现象:shutdown电压设置在2V,DSG 早已经被关闭,当进入后,我再激活,,CHG打开,然后接入充电器,但是 CHG一直打开-关闭,打开...打嗝,电池不能正常充电

解决过程:

建议请确认一下是不是进入PCHGC :Over- precharge current,可以试着提供设置的precharge 电流充电试一下。

 

试过降低电流 也不行,一直打嗝。几分钟后,恢复正常。但是始终不知道哪儿出的问题。 接上位机,也寄存器 也一直乱跳

image-20200811090806-1.png

 

image-20200811090830-2.png image-20200811090849-3.png


回复

2万

帖子

337

资源

版主

建议:参考TRM 19.2.4.5EnabledProtectionsD 将PCHGC disable反过来验证一下是不是预充过流引起的保护。

 

这些C,D项都是关闭的。如果有保护,寄存器能报告出来。 很奇怪的是,打嗝 像是不停的复位,因为date merroy 里面都是乱了。明明已经充到 解除shutdown电压了,SDV也清除了。还是一直跳,更奇怪的是 当DSG 恢复后,也跟着跳。
此时 如果不充电了,shutdown解除了,就一直打嗝,直到再充几分钟后,才解除。

 

建议:可以log一些数据,将当时的画面截图发过来看一下,测试的流程是什么样的。

 

也根本没法log数据,一直跳
1,我直接对电芯放电,
2,shutdown 设置2.5V,
3,电芯放电很低1.几V后,早已经进入shutdown
4,预充电设置使用的 是主CHG 管子 PCHG comment
5,激活一下电路,接上充电器,就开始跳了。
6,如果直接对电芯充电,芯片不走电流,当电芯电压在shutdown 值上时,是正常

现象:
只要是激活了,通过充电电流后,芯片工作就不正常,充电管子 打开-关闭,打开,直到充几分钟

 

 

 


回复

2万

帖子

337

资源

版主

终于找出问题了,如果LEDCHG 开启了,进入shutdown 后,再激活,充电,就会变成神经病状态。

折腾了 几天才找出问题,

而且这明显的是个芯片BUG,毫无依据,完全是我蒙出来的结果

看这个LED 灯 在正常闪的时候,同时功能正常。

就把它关闭了,进入shutdown,充电试试,就正常了, 

image-20200811091138-1.png

 


回复

4

帖子

0

资源

一粒金砂(初级)

楼主,感谢你把这个bug分享给大家,我也遇到了类似的问题。再请教您一个问题,关闭了CHGLED,那么充电就不会有LED亮,我认为充电时LED不亮有些不合理,请问您是怎么处理这个问题的?接受充电时LED不亮么


回复

3185

帖子

1

资源

五彩晶圆(初级)

经验之谈,多多此类文章就好啦。

个人签名人已离开,无事别找,找也找不到。

回复
您需要登录后才可以回帖 登录 | 注册

最新文章 更多>>
    关闭
    站长推荐上一条 1/6 下一条

    About Us 关于我们 客户服务 联系方式 器件索引 网站地图 最新更新 手机版

    站点相关: 安防电子 汽车电子 手机便携 工业控制 家用电子 医疗电子 测试测量 网络通信 物联网

    北京市海淀区知春路23号集成电路设计园量子银座1305 电话:(010)82350740 邮编:100191

    电子工程世界版权所有 京ICP证060456号 京ICP备10001474号-1 电信业务审批[2006]字第258号函 京公网安备 11010802033920号 Copyright © 2005-2021 EEWORLD.com.cn, Inc. All rights reserved
    快速回复 返回顶部 返回列表