社区导航

 

搜索
查看: 388|回复: 3

[求助] 请问为什么EPS32跑micropython没看见bluetooth的函数?

[复制链接]

14

TA的帖子

0

TA的资源

一粒金砂(中级)

Rank: 2

发表于 2020-2-29 22:30 | 显示全部楼层 |阅读模式

问问各位:esp32不是wifi和BLE双模的吗?

为什么在micropython里面没有 2020-02-29 22_28_24-Quick reference for the ESP32 — MicroPython 1.12 documentation.png 包含操作BLE的函数?那esp32不就是略强点的8266吗?

补充内容 (2020-3-22 17:08): 已经有结论了,请翻翻我在本帖中的其他内容


回复

使用道具 举报

9960

TA的帖子

14

TA的资源

版主

Rank: 6Rank: 6

测评达人

发表于 2020-2-29 22:41 | 显示全部楼层

是的,同时支持BLE和wifi。目前固件分两个版本:支持蓝牙的版本和不支持蓝牙的版本。



回复

使用道具 举报

14

TA的帖子

0

TA的资源

一粒金砂(中级)

Rank: 2

 楼主| 发表于 2020-2-29 23:14 | 显示全部楼层

感谢版主的提醒,1.12的release里是包含了BLE的,我打算去跑一下这个版本。



回复

使用道具 举报

14

TA的帖子

0

TA的资源

一粒金砂(中级)

Rank: 2

 楼主| 发表于 2020-3-22 17:21 | 显示全部楼层

2020-03-22 17_09_25-1.png 按版主说的,我就去找可以用ble的固件去了。

micropython自己在1.12的release中说是已经嵌入到主线了

第一次烧写的是esp32-idf3-20191220-v1.12.bin,好吧,根本就不能导入蓝牙模块。。。。。

然后就去找源码,找呀找,找扩展模块的开关,没找到,看到make里面,默认就是编译进去的。。。。

重编译?我想到了,但是我的乐鑫idf环境根本就过不去。。报版本过高。。。。我也是新手撒,不懂呢

(此处过了好多天)

现在说结果吧,我现在烧写的固件是:esp32-idf3-20200322-v1.12-263-g8d34344dc.binesp32-idf4-20200322-v1.12-263-g8d34344dc.bin

这两个固件里都有ubluetooth模块,都有~

结论,新的主线固件已经支持蓝牙了,idf3和idf4都支持。

动手吧,洪哥(们)~

 



回复

使用道具 举报

您需要登录后才可以回帖 登录 | 注册

关闭

站长推荐上一条 1/6 下一条

  • 论坛活动 E手掌握

    扫码关注
    EEWORLD 官方微信

  • EE福利  唾手可得

    扫码关注
    EE福利 唾手可得

Archiver|手机版|小黑屋|电子工程世界 ( 京ICP证 060456 )

GMT+8, 2020-3-29 23:09 , Processed in 0.156184 second(s), 18 queries , Gzip On, MemCache On.

快速回复 返回顶部 返回列表